#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<unit_type>SF)(?P<unit_size>500|400|350|300|250|200|150|125)(?P<mounting_type>A|B|K)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<cracking_pressure>1)(?P<sep_2>-)(?P<unit_series>4X)(?P<sep_3>/)(?P<type_of_limit_switch>Q2|)(?P<power_supply_of_limit_switch>G24Z|)(?P<seal_material>|)(?P<pipe_port>|)(?P<special_version>SO102|SO104|)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "SF200A1-1-4X/" & @CRLF & _
"SF250A1-1-4X/" & @CRLF & _
"SF400A1-1-4X/" & @CRLF & _
"SF200K0-1-4X/" & @CRLF & _
"SF150A1-1-4X/" & @CRLF & _
"SF125B1-1-4X/" & @CRLF & _
"SF125A1-1-4X/" & @CRLF & _
"SF200B1-1-4X/" & @CRLF & _
"SF150B1-1-4X/" & @CRLF & _
"SF250B1-1-4X/" & @CRLF & _
"SF250A0-1-4X/" & @CRLF & _
"SF150A0-1-4X/" & @CRLF & _
"SF300A1-1-4X/" & @CRLF & _
"SF200K0-1-4X/SO72" & @CRLF & _
"SF125A0-1-4X/" & @CRLF & _
"SF300A0-1-4X/" & @CRLF & _
"SF300B1-1-4X/" & @CRLF & _
"SF350A0-1-4X/" & @CRLF & _
"SF250K0-1-4X/" & @CRLF & _
"SF200A0-1-4X/" & @CRLF & _
"SF150K0-1-4X/" & @CRLF & _
"SF125B0-1-4X/" & @CRLF & _
"SF150B0-1-4X/" & @CRLF & _
"SF200B0-1-4X/" & @CRLF & _
"SF350A1-1-4X/" & @CRLF & _
"SF500A1-1-4X/" & @CRLF & _
"SF150K0-1-4X/SO72" & @CRLF & _
"SF125K0-1-4X/" & @CRLF & _
"SF400A0-1-4X/" & @CRLF & _
"SF250B0-1-4X/" & @CRLF & _
"SF350B1-1-4X/" & @CRLF & _
"SF300K0-1-4X/" & @CRLF & _
"SF250K0-1-4X/SO72" & @CRLF & _
"SF300K0-1-4X/SO72" & @CRLF & _
"SF300B0-1-4X/" & @CRLF & _
"SF250B1-1-4X/SO103" & @CRLF & _
"SF125K0-1-4X/V" & @CRLF & _
"SF125B1-1-4X/SO103" & @CRLF & _
"SF400B1-1-4X/" & @CRLF & _
"SF125A1-1-4X/SO103" & @CRLF & _
"SF200A1-1-4X/SO103" & @CRLF & _
"SF150B1-1-4X/V" & @CRLF & _
"SF250A1-1-4X/SO103" & @CRLF & _
"SF150B1-1-4X/SO103" & @CRLF & _
"SF200K0-1-4X/SO103" & @CRLF & _
"SF300K0-1-4X/V" & @CRLF & _
"SF350B0-1-4X/" & @CRLF & _
"SF150A0-1-4X/V" & @CRLF & _
"SF150A1-1-4X/SO103" & @CRLF & _
"SF150A0-1-4X/Q2G24" & @CRLF & _
"SF200A0-1-4X/Q2G24" & @CRLF & _
"SF250A0-1-4X/Q2G24" & @CRLF & _
"SF300A0-1-4X/Q2G24" & @CRLF & _
"SF400A0-1-4X/Q2G24" & @CRLF & _
"SF500B1-1-4X/" & @CRLF & _
"SF125A0-1-4X/Q2G24" & @CRLF & _
"SF250A0-1-4X/V" & @CRLF & _
"SF350A0-1-4X/Q2G24" & @CRLF & _
"SF350A1-1-4X/V" & @CRLF & _
"SF125A1-1-4X/V" & @CRLF & _
"SF500A0-1-4X/Q2G24" & @CRLF & _
"SF125A0-1-4X/Q2G24SO103" & @CRLF & _
"SF250K0-1-4X/SO92" & @CRLF & _
"SF200B1-1-4X/SO103" & @CRLF & _
"SF150B0-1-4X/500" & @CRLF & _
"SF150A0-1-4X/500" & @CRLF & _
"SF200B0-1-4X/500" & @CRLF & _
"SF200A0-1-4X/500" & @CRLF & _
"SF250B0-1-4X/500" & @CRLF & _
"SF250A0-1-4X/500" & @CRLF & _
"SF300A0-1-4X/500" & @CRLF & _
"SF300B0-1-4X/500" & @CRLF & _
"SF500A1-1-4X/Q2G24" & @CRLF & _
"SF200A0-1-4X/500Q2G24" & @CRLF & _
"SF300A0-1-4X/500Q2G24" & @CRLF & _
"SF400B0-1-4X/" & @CRLF & _
"SF400A1-1-4X/Q2G24" & @CRLF & _
"SF250A0-1-4X/SO43A1840" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")