$re = '/(?s)"(?:[^"\\\\\n]|\\\\.)*"/';
$str = '"a \\" b"
"a \\
b"
"\\\\"
"\\\\\\
kjsh\\a\\b\\tdfkj\\"\\\\\\\\\\\\"
"kjsdhfksd f\\\\\\\\"
"kjsdhfksd f\\\\\\""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);