using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)""(?:[^""\\]|\\.)*""";
string input = @"""a \"" b""
""a \
b""
""a string with \\\"" double slash at the end\\""
""\\""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}