package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:music|pictures)\/tom((?:\/(?:[\w-]+(?:[ ]+[\w-]+)*))*)(\/(?:[\w-]+(?:[ ]+[\w-]+)*))$`)
var str = `music/tom/foldername
music/tom/folder name
music/tom/abc/foldername/folder2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}