// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<a(?:\s+\w+\s*=\s*(?P<quote>["']).*?(?P=quote))*)\s+class\s*=\s*(?P<q>["']).*?(?P=q)"#).unwrap();
let string = "<p class=\"red\">Link: <a href=\"http://www.google.com\" style =\"margin: 0px\">google</a>.</p>
<p class=\"red\">Link: <a href=\"http://www.google.com\" class = \"link\" style=\"margin: 0px\" >google</a>.</p>
<a class='foo'>link text</a>";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}