package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([\+-]?[0-9]+)x|([\+-]?[0-9]*)y`)
var str = `3x+1y
10x-2y
-5x+2y
-10x+5y`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}