$re = '/([\+-]?[0-9]+)x|([\+-]?[0-9]*)y/im';
$str = '3x+1y
10x-2y
-5x+2y
-10x+5y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);