// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)([\+-]?[0-9]+)x|([\+-]?[0-9]*)y").unwrap();
let string = "3x+1y
10x-2y
-5x+2y
-10x+5y";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}