use strict;
my $str = '2 St James Cl Glossop DERBYSHIRE SK13 8JX
27 The Shires Marshfield Cardiff NEWPORT CF3 2AX
Unnamed Road Isle of Benbecula NA H-EILEANAN AN IAR HS7 5LY
Muscovy St LONDON EC3R 5BA
27 Louise St Chester CHESHIRE WEST AND CHESTER CH1 4HP UK
15 Whiteladies Rd Bristol CITY OF BRISTOL BS8 2NN UK
Flat 3 2A Klea Avenue LONDON SW4 9JA London
41 Longthornton Road LONDON SW16 5QE GREATER LONDON
127 Cedars Road LONDON SW4 0PS London
108 Culvert Road LONDON SW11 5AX London
308 Wellington Road South HOUNSLOW TW4 5JT Hounslow
15 Arnott Quadrant MOTHERWELL ML1 3TQ North Lanarkshire
12 Parish Close Dawley TELFORD TF4 3ER Shropshire
76 Admiralty Close WEST DRAYTON UB7 9NJ West Drayton
56 Glenburn Avenue MOTHERWELL ML1 5EF North Lanarkshire
25 Thirleby Road EDGWARE HA8 0HF Edgware
21 Prideaux Place Friars Place Lane LONDON W3 7AS London
1 Arnold Road STAINES-UPON-THAMES TW18 1LY Surrey
6 Queen Street BRIDGWATER TA6 3DA Somerset
Flat 8 Lynn Court Mitcham Lane LONDON SW16 6LL London
35 Weirside Gardens WEST DRAYTON UB7 7TL
473 Rochfords Gardens SLOUGH SL2 5XF Berkshire
155 Strawberry Fields ADDLESTONE KT15 1FJ Surrey
6 Lundy Drive HAYES UB3 4ES Hayes
67 Daubney Street CLEETHORPES DN35 7BB Lincolnshire
38 Hurleybrook Way Leegomery TELFORD TF1 6TX Shropshire
7 Sanderson Avenue Uddingston GLASGOW G71 6JR North Lanarkshire
18 Swaythling Close LONDON N18 2QG London
10A Castle Court WHITCHURCH SY13 1DE Shropshire
Flat 41 Burnside Tower MOTHERWELL ML1 2BA North Lanarkshire
42 Melrose Avenue Chapelhall AIRDRIE ML6 8TE North Lanarkshire
18 Alfred Road LONDON SE25 5LE London
72 St. James Road WATFORD WD18 0DX Hertfordshire
49 Graham Road MITCHAM CR4 2HB Mitcham
14 Woodside Crescent Newmains WISHAW ML2 9LX North Lanarkshire
182 Dalriada Crescent MOTHERWELL ML1 3XS North Lanarkshire
2 High Lift Villas Skye Hall Hill Boxted Colchester ESSEX CO4 5TD UK
1 Casterbridge Hill Street Calmore Southampton HAMPSHIRE SO40 2RX UK
3 Earl\'s Ct Fifth Ave Team Valley Trading Estate Gateshead TYNE AND WEAR NE11 0HF UK
1 Meadow Dr Hampton in Arden Solihull WEST MIDLANDS B92 0BD UK
1 Amotherby Ln Amotherby Malton NORTH YORKSHIRE YO17 6TG UK
39 Nightingale Way Midsomer Norton Radstock BATH AND NORTH EAST SOMERSET BA3 4NL UK
7 Macredie Pl Perceton Irvine NORTH AYRSHIRE KA11 2BF UK
13 Montague Ave Conisbrough Doncaster SOUTH YORKSHIRE DN12 3PS UK
389 Innsworth Ln Churchdown Gloucester GLOUCESTERSHIRE GL3 1HA UK
5 Harris Cl Newborough Peterborough PETERBOROUGH PE6 7AJ UK
16 Drury Ln Altofts Normanton WEST YORKSHIRE WF6 2JN UK
5 Ael-Y-Bryn Trelewis Treharris MERTHYR TYDFIL CF46 6BA UK
44 West Cres Chopwell Newcastle upon Tyne TYNE AND WEAR NE17 7HD
3 Buckingham Square Helmsley York NORTH YORKSHIRE YO62 5DZ UK
3 Monument Cl Tittensor Stoke-on-Trent STAFFORDSHIRE ST12 9JL UK
27 Halbullock View Gloweth Truro CORNWALL TR1 3WW UK
3 Gwyddon Rd Abercarn Newport CAERPHILLY NP11 5GX UK
2B Ballyoran Ln Dundonald Belfast CASTLEREAGH BT16 1XJ UK
63 Kensington Dr Great Holm Milton Keynes MILTON KEYNES MK8 9AW UK
3 Donich View Lochgoilhead Cairndow ARGYLL AND BUTE PA24 8AP UK
33 Knowehead Rd Hurlford Kilmarnock EAST AYRSHIRE KA1 5EQ UK
9 Bishopdale Rise Mosborough Sheffield SOUTH YORKSHIRE S20 5PE UK
8 Byland Cl Boston Spa Wetherby WEST YORKSHIRE LS23 6PU UK
10 Park Way Rednal Birmingham WEST MIDLANDS B45 9PL UK
68A Earlswood Rd Dorridge Solihull WEST MIDLANDS B93 8RH UK
18 Angus Cl Shaw Swindon SWINDON SN5 5PS UK
4 Garbo Cl Crownhill Milton Keynes MILTON KEYNES MK8 0EA UK
2124 Market Way Team Valley Trading Estate Gateshead TYNE AND WEAR NE11 0RE UK
7 Blenkinsopp Castle Inn Greenhead Brampton NORTHUMBERLAND CA8 7JN UK
23 Sherry Heights Cambuslang Glasgow SOUTH LANARKSHIRE G72 7HH UK
1 Inchmore Struy Kiltarlity Beauly HIGHLAND IV4 7JX UK
155A Bedford Rd Wilstead Bedford BEDFORD MK45 3HU UK
11 Almond Cl Llantwit Fardre Pontypridd RHONDDA CYNON TAFF CF38 2PX UK
2 Pettits Cl Fulbourn Cambridge CAMBRIDGESHIRE CB21 5BJ UK
1 Rothbury Cl Trimdon Grange Trimdon Station COUNTY DURHAM TS29 6PD UK
1 Mill of Brotherfield Skene Westhill ABERDEENSHIRE AB32 6SQ UK
1 Broadmeadow Cl Totton Southampton HAMPSHIRE SO40 8WB UK
72 Parish Rd Beddau Pontypridd RHONDDA CYNON TAFF CF38 2BU UK
Kiln Ln Leece Ulverston CUMBRIA LA12 0QZ UK
5 Builth Cl Duffryn Newport NEWPORT NP10 8HU UK
3 Caladh-na-Sith Bruichladdich Isle of Islay ARGYLL AND BUTE PA49 7UN UK
336 Almondvale S Livingston WEST LOTHIAN EH54 6HR UK
162 Drum Rd Cookstown COOKSTOWN BT80 9DW UK
119-129 Bath St Glasgow GLASGOW CITY G2 2DR UK
3 Cherry Tree Cl Saint Leonards-on-sea EAST SUSSEX TN37 6EX UK
3 Carregoffa Cottages Llanymynech POWYS SY22 6LA UK
5 Castle Goring Mews Worthing WEST SUSSEX BN13 3UD UK
2A Newlands Dr Halesowen WEST MIDLANDS B62 9DU UK
223 Chatsworth Ave Portsmouth PORTSMOUTH PO6 2UL UK
41 Castle Terrace Aberdeen ABERDEEN CITY AB11 5EA UK
244 St Margaret\'s Rd Bradford WEST YORKSHIRE BD7 2BU UK
16 Woodbine Rd Sidcup GREATER LONDON DA15 8JJ UK
4 New Houses Isle of Eigg HIGHLAND PH42 4RL UK
2 Tripps Hill Cl Chalfont Saint Giles BUCKINGHAMSHIRE HP8 4JZ UK
112 Ardingly Dr Worthing WEST SUSSEX BN12 4TP UK
6A Ellenslea Rd Saint Leonards-on-sea EAST SUSSEX TN37 6HY UK
20 Surrey Dr Congleton CHESHIRE EAST CW12 1NU UK
Unnamed Road Hull EAST RIDING OF YORKSHIRE HU11 4NZ UK
1 Hay Park Loan Galashiels SCOTTISH BORDERS TD1 2SF UK
Chestnut Ave Penmaenmawr CONWY LL34 6TH UK
11 Smithills Cl Chorley LANCASHIRE PR6 0EG UK
Silverdale Rd Settle NORTH YORKSHIRE BD24 9PN UK
1 and 2 Westmill Cottages Auchterarder PERTH AND KINROSS PH3 1DP UK
1 Booth\'s Hill Rd Lymm WARRINGTON WA13 0DJ UK
Coed-Yr-Ynys Rd Crickhowell POWYS NP8 1NA UK
38 Main St Nottingham NOTTINGHAMSHIRE NG1 1AB UK
9 Meerbrook Cl Stoke-on-Trent STOKE-ON-TRENT ST4 8TR UK
167 Crocketts Rd Birmingham WEST MIDLANDS B21 0HS UK
3 St Johns Ave Epsom SURREY KT17 3BE UK
71 Lisanally Ln Armagh ARMAGH BT61 7HF UK
Little London St Norwich NORFOLK NR2 1AN UK
21 Westgarth Rd Kirkby Stephen CUMBRIA CA17 4TF UK
6 St Peters Rd Rugby WARWICKSHIRE CV21 3QR UK
56 Ingestre Rd Birmingham WEST MIDLANDS B28 9EG UK
56 Hawthorn Cres Beith NORTH AYRSHIRE KA15 1BZ UK
Highlander Rd Chester CHESHIRE WEST AND CHESTER CH3 6BB UK
2 Blegbie Cottages Humbie EAST LOTHIAN EH36 5PN UK
Sake Ride Ln Henfield WEST SUSSEX BN5 9AS UK
47 Grammerscroft Millom CUMBRIA LA18 5EL UK
Best St Chatham MEDWAY ME4 4AB UK
15 Gordon Pl Tain HIGHLAND IV20 1TD UK
Skittle Green Princes Risborough BUCKINGHAMSHIRE HP27 9PJ UK
4 Market Pl Nottingham NOTTINGHAMSHIRE NG6 8QA UK
49A William St Helensburgh ARGYLL AND BUTE G84 8XY UK
11 Cumberland Walk Newcastle upon Tyne TYNE AND WEAR NE7 7SX UK
99 Pinewood Green Iver BUCKINGHAMSHIRE SL0 0QN UK
19 Darnley Rd Gravesend KENT DA11 0RZ UK
504 Upper Thames St LONDON EC4V 3EH UK
1 Bourne Valley Rd Poole POOLE BH12 1DS UK
12/3 Rankin Dr Edinburgh EDINBURGH EH9 3DE UK
31 Leadhall Ln Harrogate NORTH YORKSHIRE HG2 9NJ UK
Flower Ln Godstone SURREY RH9 8BG UK
120 High St Hungerford WEST BERKSHIRE RG17 0LU UK
6 Whitworth Cl Gateshead TYNE AND WEAR NE8 4UW UK
5 Dromara Rd Hillsborough LISBURN BT26 6HY UK
22 Maitland Terrace Newbiggin-by-the-Sea NORTHUMBERLAND NE64 6UR UK
50 W Shore Rd Edinburgh EDINBURGH EH5 1QH UK
B846 Pitlochry PERTH AND KINROSS PH17 2QA UK
Unnamed Road Cullompton DEVON EX15 2AH UK
15 Mayor\'s Walk Peterborough PETERBOROUGH PE3 6EU UK
15 Glenmount Rd NEWTOWNABBEY BT37 9BW UK
63 Cefn-Y-Bryn Llandudno CONWY LL30 1NL UK
27 Louise St Chester CHESHIRE WEST AND CHESTER CH1 4HP UK
76 Stoneyhurst Ave Burnley LANCASHIRE BB10 4NL UK
4 Oakcroft Villas Chessington GREATER LONDON KT9 1RJ UK
27 Catherine St Bristol CITY OF BRISTOL BS11 9LG UK
Kings Ct Falkirk FALKIRK FK1 1PQ UK
27 Randolph Rd Glasgow GLASGOW CITY G11 7LF UK
London Rd Nantwich CHESHIRE EAST CW5 7QB UK
3 Athol Square Poplar LONDON E14 0NP UK
4 Moor Ln Skipton NORTH YORKSHIRE BD23 6EJ UK
6 Wasdale Cl Cramlington NORTHUMBERLAND NE23 6LN UK
103-105 Lower Luton Rd Harpenden HERTFORDSHIRE AL5 5AL UK
Doddington Rd Chatteris CAMBRIDGESHIRE PE16 6UJ UK
13 Manor Farm Rd Enfield GREATER LONDON EN1 4SH UK
3 The Meadows Watlington OXFORDSHIRE OX49 5JN UK
1 Campbelltown Cottages Leckmelm Lochbroom Garve HIGHLAND IV23 2RH
188 Thames Rd Stockton-on-Tees Billingham STOCKTON-ON-TEES TS22 5EF
11 Old Station Ct Strathyre Callander STIRLING FK18 8NL
2 Westcotts Hollocombe Chulmleigh DEVON EX18 7QE
11 Swan Bank Ct Swan Bank Ln Holmfirth WEST YORKSHIRE HD9 2DS
10 St Mary\'s Cl Roughton Norwich NORFOLK NR11 8QF
2 Well Cottages Tutwell Callington CORNWALL PL17 8LU
28 Llwyni Drive Connah\'s Quay Deeside FLINTSHIRE CH5 4NE
5 Elliot Cl South Woodham Ferrers Chelmsford ESSEX CM3 5YN
4 Buckingham Cl Georgenympton Rd South Molton DEVON EX36 4ER
117 Hannahston Ave Drongan Ayr EAST AYRSHIRE KA6 7AX
1 Maes Merddyn Bungalows Carreglefn Amlwch ISLE OF ANGLESEY LL68 0PD
3 West View Hawthorn Seaham COUNTY DURHAM SR7 8SQ
41 Killough Rd Ardglass Downpatrick COUNTY DOWN BT30 7UG
2 Inchloan Steadings Durris Banchory ABERDEENSHIRE AB31 6DL
20 Main Rd Knockholt Sevenoaks KENT TN14 7LD
49 Daniell Rd Wellesbourne Warwick WARWICKSHIRE CV35 9UD
45 Ellesmere Orchard Westbourne Emsworth WEST SUSSEX PO10 8TP
2124 Market Way Team Valley Trading Estate Gateshead TYNE AND WEAR NE11 0RE
1 Thrush Hill Rd Mytholmroyd Hebden Bridge WEST YORKSHIRE HX7 5AQ
2 Church View Broughton Kettering NORTHAMPTONSHIRE NN14 1LX
4 Anderson Dr Killen Avoch HIGHLAND IV9 8RH
2 Gipsy Ln Woodlesford Leeds WEST YORKSHIRE LS26 8SA
B1064 Long Melford Sudbury SUFFOLK CO10 9HY
2 Frood Cl Chapel-en-le-Frith High Peak DERBYSHIRE SK23 0JS
46 Fordham Rd London Barnet GREATER LONDON EN4 9AQ
49 Marine Parade Millport Isle of Cumbrae NORTH AYRSHIRE KA28 0EF
1 Glanton Ct Faverdale Darlington DARLINGTON DL3 0NY
97 Occupation Rd Harley Rotherham SOUTH YORKSHIRE S62 7UQ
2 The Row Wretham Thetford NORFOLK IP24 1RH
26 Pepys Terrace Impington Cambridge CAMBRIDGESHIRE CB24 9NT
38 Orrell Ln Burscough Ormskirk LANCASHIRE L40 0SQ
10 Elderberry Cl Langdon Hills Basildon ESSEX SS16 6RL
39 Rothbury Cl Trimdon Grange Trimdon Station COUNTY DURHAM TS29 6PD
4 Avards Cl Hawkhurst Cranbrook KENT TN18 4EJ
1 Burnside Cl Boldon Colliery TYNE AND WEAR NE35 9BU
1 Ivy Cottages Gunnislake CORNWALL PL18 9NP
1 Lyngford Square Taunton SOMERSET TA2 7ES
1 Portfield Haverfordwest PEMBROKESHIRE SA61 1BW
1 Slate Cl Delabole CORNWALL PL33 9EN
1 Thornden Ln Glasgow GLASGOW CITY G14 0XQ
10 Nora St Warrington WARRINGTON WA1 2JG
104 Alston Rd Solihull WEST MIDLANDS B91 2RG
11 Cumberland Walk Newcastle upon Tyne TYNE AND WEAR NE7 7SX
11 Livingstone Rd Broadstairs KENT CT10 2UD
115-119 Murray St Montrose ANGUS DD10 8JQ
117 Heathcote Dr East Grinstead WEST SUSSEX RH19 1NG
12 Lord St Barnsley SOUTH YORKSHIRE S71 1HZ
125 Brown Lees Rd Stoke-on-Trent STAFFORDSHIRE ST8 6PN
14 Raise St Saltcoats NORTH AYRSHIRE KA21 5JU
15 Sidmouth Rd Lytham Saint Annes LANCASHIRE FY8 2QZ
1-7 Westbourne Rd Bedford BEDFORD MK40 4LB
18 Granville St Rossendale LANCASHIRE BB4 4LD
18 Mullard Dr Leamington Spa WARWICKSHIRE CV31 2QE
18 Queen\'s Ave Sunderland TYNE AND WEAR SR6 8DL
19 Berrycoombe Vale Bodmin CORNWALL PL31 2PH
190 Elgar Ave Malvern WORCESTERSHIRE WR14 2HA
190 Partington Ln Swinton MANCHESTER M27 0WN
1B Prestongrange Rd Prestonpans EAST LOTHIAN EH32 9SL
2 Braekirk Ave Kirknewton WEST LOTHIAN EH27 8BL
2 Crowhurst Mead Godstone SURREY RH9 8BF
2 Hillcrest Ct Brackley NORTHAMPTONSHIRE NN13 6QA
2 Lowick Gardens Peterborough PETERBOROUGH PE3 7HQ
2 Roundhaye Gardens Bournemouth BOURNEMOUTH BH11 9JU
2 Upper Church St Ashby-de-la-Zouch LEICESTERSHIRE LE65 1BX
21 Lammas Rd Godalming SURREY GU7 1YL
21 Luss Ave Greenock INVERCLYDE PA15 3EQ
22 Russell Rd Gravesend KENT DA12 2RT
22-24 Collingham Pl Kensington LONDON SW5 0PZ
26 William Morris Ave Rowlands Gill TYNE AND WEAR NE39 2DD
267 Vardon Rd Stevenage HERTFORDSHIRE SG1 5PZ
26A The Cir Birmingham WEST MIDLANDS B17 9DY
276 Charles St Leigh LEIGH WN7 1PP
2A Park Terrace Greenhithe KENT DA9 9EL
3 Agate St Bristol CITY OF BRISTOL BS3 3AQ
3 E Croft Beckermet CUMBRIA CA21 2XF
3 Frankwell Llanidloes POWYS SY18 6HG
30 Coalway Rd Wolverhampton WEST MIDLANDS WV3 7LX
31 Churchill Ave Bourne LINCOLNSHIRE PE10 9QA
31 Coronation Ave Blackburn BLACKBURN WITH DARWEN BB2 5EL
31 Filder Cl Eastbourne EAST SUSSEX BN22 8SY
31C Shore St Macduff ABERDEENSHIRE AB44 1TS
338 Bradford Rd Otley WEST YORKSHIRE LS21 3LT
34 Ettiley Ave Sandbach CHESHIRE EAST CW11 3ND
34 Union Rd Grangemouth FALKIRK FK3 8AB
36 Baird St Glasgow GLASGOW CITY G4 0PT
376 Higginshaw Ln Royton OLDHAM OL2 6HQ
376 Higginshaw Ln Royton OLDHAM OL2 6HQ
39 Parish Gardens Leyland LANCASHIRE PR25 3UF
4 Greenscoe Askam-in-Furness CUMBRIA LA16 7HE
4 Lady Hill View Avoch HIGHLAND IV9 8RU
4 Lorraine Cl Port Talbot NEATH PORT TALBOT SA12 6PJ
4 Mulberry Mews Lewisham Way LONDON SE14 6QF
41 Macer\'s Ln Broxbourne HERTFORDSHIRE EN10 6EA
45-51 Park St Camberley SURREY GU15 3PG
5 Baden Powell Rd Turriff ABERDEENSHIRE AB53 4FA
5 Great Conduit Welwyn Garden City HERTFORDSHIRE AL7 2DH
5 Mulgrove Walk Manchester MANCHESTER M9 6SN
5 Prescott St Hindley WIGAN WN2 3ET
50 Dane Rd Southall GREATER LONDON UB1 2EB
50 Nettleton St Ossett WEST YORKSHIRE WF5 8HG
52 Rosemount Park Newtownabbey NEWTOWNABBEY BT37 0NL
53 Heath Park Rd Romford GREATER LONDON RM2 5UL
57 Booth St Birmingham WEST MIDLANDS B21 0NH
57 Prospect Ave Halifax WEST YORKSHIRE HX2 7HP
6 George St Hertford HERTFORDSHIRE SG14 3AD
6 Kings Dr Egremont CUMBRIA CA22 2LE
6 Lord Sheldon Way Ashton-under-Lyne ASHTON-UNDER-LYNE OL6 7UB
6 St Clement Ave Dunblane STIRLING FK15 9DG
6 St James\' Rd Birmingham WEST MIDLANDS B21 0HL
63 Meadowbrook Rd Halesowen WEST MIDLANDS B63 1AL
6A Boxfield Rd Axminster DEVON EX13 5LB
73 S Parade Elland WEST YORKSHIRE HX5 0NR
76 Norman Rd Walsall WEST MIDLANDS WS5 3QN
79 Stanton St Manchester MANCHESTER M11 4NZ
8 Hilliers Ln Croydon GREATER LONDON CR0 4SU
8 Penleigh Cl Lancing WEST SUSSEX BN15 8EP
85 Broadway Gateshead TYNE AND WEAR NE9 5QB
88 Wildwood Ln Stevenage HERTFORDSHIRE SG1 1TD
886 Bradford Rd Batley WEST YORKSHIRE WF17 8NN
89 Premier Rd Middlesbrough MIDDLESBROUGH TS3 8QW
95 Sunrising Estate Looe CORNWALL PL13 1NG
A188 Newcastle upon Tyne TYNE AND WEAR NE7 7EG
A39 Truro CORNWALL TR3 6JX
A595 Millom CUMBRIA LA19 5UG
A827 Killin STIRLING FK21 8TS
A97 Huntly ABERDEENSHIRE AB54 4PY
A99 Lybster HIGHLAND KW2 6AA
B5256 Leyland LANCASHIRE PR26 7PA
B8035 Isle of Mull ARGYLL AND BUTE PA68 6EJ
B953 Perth PERTH AND KINROSS PH14 9RE
Back Row Leeds WEST YORKSHIRE LS11 5AN
Century Dr Braintree ESSEX CM77 8YG
Ffordd Tyddyn-Y-Felin Talybont GWYNEDD LL43 2AY
Harap Rd Trimdon Station COUNTY DURHAM TS29 6NB
Maldon Rd Witham ESSEX CM8 3HY
Rhiw Felen Crymych PEMBROKESHIRE SA41 3UE
Townsend Shepton Mallet SOMERSET BA4 5AX
Unnamed Road Crickhowell POWYS NP8 1TA
Unnamed Road Keith MORAY AB55 6XU
Unnamed Road Penrith CUMBRIA CA10 2PT
Unnamed Road Chepstow MONMOUTHSHIRE NP16 6HQ
10 Morecambe Cl LONDON E1 4NH
10 Stafford Park 12 TELFORD TF3 3BJ
18 Henning St LONDON SW11 3DR
19 Kirkgate Ln MILNTHORPE LA7 7FL
2 A851 ISLE OF SKYE IV44 8RP
25 Derwent Rise LONDON NW9 7HX
3 Vesty Rd BOOTLE L30 1NY
43 Great Russell St LONDON WC1B 3PD
5 Taylor St LEIGH WN7 5NQ
55 Corker Walk LONDON N7 7RU
Austin Friars Passage LONDON EC2N 2HG
';
my $regex = qr/(?:[A-Za-z]\d ?\d[A-Za-z]{2})|(?:[A-Za-z][A-Za-z\d]\d ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d{2} ?\d[A-Za-z]{2})|(?:[A-Za-z]\d[A-Za-z] ?\d[A-Za-z]{2})|(?:[A-Za-z]{2}\d[A-Za-z] ?\d[A-Za-z]{2})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";