using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"aaa.+(?=[^}]*dog[^}]*)[^}]+";
string input = @" [{
aaa: true,
some: 'cat goes meow',
zzz: true
},{
aaa: true,
some: 'dog goes woof',
zzz: true
}];";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}