#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)([#]+)[ \t]+([\S]+[^\n]+)"
Local $sString = "# header with spaces👍" & @CRLF & _
"#noheader" & @CRLF & _
"# " & @CRLF & _
"# 🔥123" & @CRLF & _
"" & @CRLF & _
"asdasdasd" & @CRLF & _
"# 🔥" & @CRLF & _
"# This is 🔥" & @CRLF & _
"#" & @CRLF & _
"# header" & @CRLF & _
"# dasdadsa" & @CRLF & _
"## dasd" & @CRLF & _
"### asdas" & @CRLF & _
"#### asdasd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" # adsasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")