#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\b\d{4}\b\s*\b[A-Z]{3,11}\s*\b(?!(INTE|MANU|PMNT|Payment)\b)[A-Z]{3,10}\s*"
Local $sString = "2423 rfder INTE" & @CRLF & _
"2423 rfder MANUS" & @CRLF & _
"2423 rfder PMNT" & @CRLF & _
"2423 rfder Payment" & @CRLF & _
"2423 rfder Payments" & @CRLF & _
"2423 rfder wefwsfg" & @CRLF & _
"2423 rfder afafafddd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")