$re = '/\b\d{4}\b\s*\b[A-Z]{3,11}\s*\b(?!(INTE|MANU|PMNT|Payment)\b)[A-Z]{3,10}\s*/im';
$str = '2423 rfder INTE
2423 rfder MANUS
2423 rfder PMNT
2423 rfder Payment
2423 rfder Payments
2423 rfder wefwsfg
2423 rfder afafafddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);