using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cat\s+.*\.xml(.*)\[Expert@Arcus-mgmt1\]#\s?";
string input = @"cat namedQueries1.xml
<?xml version=""1.0"" encoding=""ISO-8859-1"" ?>
<NamedQueriesConfiguration xmlns:xsi=""http://www.w3.org/2001/XMLSchema-instance"" xsi:noNamespaceSchemaLocation=""NamedCloudQueries.xsd"">
<NamedQuery>
<Name>SC2</Name>
<RequestedInformation>AssignedIP</RequestedInformation>
<Constraint>
<FieldName>VdcName</FieldName>
<Operator>Equals</Operator>
<Value>SC2</Value>
</Constraint>
</NamedQuery>
<NamedQuery>
<Name>SC1</Name>
<RequestedInformation>AssignedIP</RequestedInformation>
<Constraint>
<FieldName>VdcName</FieldName>
<Operator>Equals</Operator>
<Value>SC1</Value>
</Constraint>
</NamedQuery>
</NamedQueriesConfiguration>[Expert@Arcus-mgmt1]#";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}