# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)\s*(?=((?!\)).)*\(|[^()]*$)/\n$1 /g;t' <<< "1Hello2Hai (in 2:3) 3hi 4 bye"