#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^((?:[0-9]{1,3}\.)){3}[0-9]{1,3}"
Local $sString = "12.123.12.122okokokko" & @CRLF & _
"asodkasdpsodaoskp" & @CRLF & _
"oasokapskdaks" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")