use strict;
my $str = '<strong>Kontaktdaten des Absenders:</strong> <br> <strong>Name:</strong> Wanted data <br> <strong>Telefon:</strong> <a dir=\'ltr\' href=\'tel:XXXXXXXXX\' x-apple-data-detectors=\'true\' x-apple-data-detectors-type=\'telephone\' x-apple-data-detectors-result=\'3\'>XXXXXXXXX</a> <br>';
my $regex = qr/(?<=<\/strong> )([^<>]*)(?= <br>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}