re = /(?<=<\/strong> )([^<>]*)(?= <br>)/
str = '<strong>Kontaktdaten des Absenders:</strong> <br> <strong>Name:</strong> Wanted data <br> <strong>Telefon:</strong> <a dir=\'ltr\' href=\'tel:XXXXXXXXX\' x-apple-data-detectors=\'true\' x-apple-data-detectors-type=\'telephone\' x-apple-data-detectors-result=\'3\'>XXXXXXXXX</a> <br>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end