use strict;
my $str = '10 990 Points';
my $regex = qr/([0-9]+)( )([A-z\s0-9]+)/mp;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";