$re = '/([0-9]+)( )([A-z\s0-9]+)/m';
$str = '10 990 Points';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;