using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(count)\s+""[^""]+""\s*((tsr|sum)\s+(<|<<)\s+(""[^""]+""|[-+]?[0-9]*\.?[0-9]+))?\s*$";
string input = @"count hede";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}