using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<response_time>\s\d+\.\d+\s)";
string input = @"192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] ""GET / HTTP/1.0"" 200 612 ""-"" ""-"" 4.038 ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}