const regex = new RegExp('(?P<response_time>\\s\\d+\\.\\d+\\s)', '')
const str = `192.168.1.1 - - [08/Sep/2014:15:15:15 +0100] "GET / HTTP/1.0" 200 612 "-" "-" 4.038 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}