package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(AB[0-9A-Z]{5}|AB[0-9]{4})`)
var str = `foo
AB0001
AB0002 foo
foo AB0003.1
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}