use strict;
my $str = 'foo
AB0001
AB0002 foo
foo AB0003.1
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005';
my $regex = qr/(AB[0-9A-Z]{5}|AB[0-9]{4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}