$re = '/(AB[0-9A-Z]{5}|AB[0-9]{4})/m';
$str = 'foo
AB0001
AB0002 foo
foo AB0003.1
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);