// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(AB[0-9A-Z]{5}|AB[0-9]{4})").unwrap();
let string = "foo
AB0001
AB0002 foo
foo AB0003.1
foo AB0004A AB0004.1
AB0005.1 foo AB0005A bar AB0005";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}