using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:;)(.*\d)";
string substitution = @"";
string input = @"<span class=""amount"">$1,286.58</span>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}