use strict;
my $str = '<span class="amount">$1,286.58</span>
';
my $regex = qr/(?:;)(.*\d)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";