$re = '/(?:;)(.*\d)/';
$str = '<span class="amount">$1,286.58</span>
';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;