package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-z]?[A-Z]+\w*(?: [a-z]?[A-Z]+\w*)+`)
var str = `Moby Dick or the White Whale by Herman Melville
Winne The Pooh by A. A. Milne
Kim by Rudyard Kipling
The United States of America
The United States Of America
WWF PandaLogo
US Navy
iPhone
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}