$re = '~\b((?!172)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\b~';
$str = 'This is an ip address in the middle of nowhere: 172.110.123.33 and this as well 192.168.1.1 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);