#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<div[^>]*id="THIS"[^>]*>(.*?)(</div>)+?" & @CRLF & _
""
Local $sString = "<div class="viewport viewport_h" style = "overflow: hidden;" >" & @CRLF & _
" <div id="THIS" class="overview overview_h">" & @CRLF & _
" <ul>" & @CRLF & _
" <li>some txt to be captured</li>" & @CRLF & _
" <li>some txt to be captured</li>" & @CRLF & _
" <li>some txt to be captured</li>" & @CRLF & _
" </ul>" & @CRLF & _
" <div>" & @CRLF & _
" " some text to be captured"" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
""some text not to be captured"" & @CRLF & _
"</div>" & @CRLF & _
"<div class="scrollbar_h">" & @CRLF & _
"<div class="track_h"></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")