Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(\w+(\.|-)*\w+)+@(\w+-?\w+)+\.[a-z]{2,3}(\.[a-z]{2})?
/
mg
Test String
New
abir.hasan.123@abir-hasan-limon.edu.bd abir.spsc@gmail.com sushipoo777@gmail.com