re = /^(\w+(\.|-)*\w+)+@(\w+-?\w+)+\.[a-z]{2,3}(\.[a-z]{2})?/m
str = 'abir.hasan.123@abir-hasan-limon.edu.bd
abir.spsc@gmail.com
sushipoo777@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end