#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w\d\._%+-]+@[\w\d.-]+\.[\w]{2,4}"
Local $sString = "zzzz@mygmail.com" & @CRLF & _
"coolio.jones@mygmail.com" & @CRLF & _
"myinvalid&crazy*email@ziggybot.co.uk" & @CRLF & _
"http://memberpress.com" & @CRLF & _
"Meet me @ 5:00 in the Lobby" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")