const regex = /[\w\d\._%+-]+@[\w\d.-]+\.[\w]{2,4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\\d\\._%+-]+@[\\w\\d.-]+\\.[\\w]{2,4}', 'g')
const str = `zzzz@mygmail.com
coolio.jones@mygmail.com
myinvalid&crazy*email@ziggybot.co.uk
http://memberpress.com
Meet me @ 5:00 in the Lobby
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}