$re = '/[\w\d\._%+-]+@[\w\d.-]+\.[\w]{2,4}/';
$str = 'zzzz@mygmail.com
coolio.jones@mygmail.com
myinvalid&crazy*email@ziggybot.co.uk
http://memberpress.com
Meet me @ 5:00 in the Lobby
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);