const regex = /\P{L}+/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\P{L}+', 'ug')
const str = `Some-string string here!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);