package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\p{M}\p{L}]+`)
var str = `Some-string string here!`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}