$re = '/^[\pL_][\pL_\pNd]*$/m';
$str = 'functionName
functionName_
_function_name
__constant__
__00000____
__________
var_name
ClassName
ClassName0
0functionName
function000Name
-varname
@varname
Class-Name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);