const regex = /^((?!0)\d{1,4}|0|\.\d{1,3})($|\.$|\.\d{1,3}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!0)\\d{1,4}|0|\\.\\d{1,3})($|\\.$|\\.\\d{1,3}$)', 'gm')
const str = `1234.123
321.1234
12.123
1.123
1.000
a.123
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}