package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]+\s*[a-zA-Z]+\s*\(\s*+long+\s*(,+\s*+[a-zA-Z]+\s*)*\)`)
var str = `int sum ( long , int)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}