# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[([^\[\]]++|(?R))*+\]"
test_str = ("<p>A body of text with a media module element embedded.<p>[[{\"fid\":\"1234\",\"view_mode\":\"full\",\"type\":\"media\",\"attributes\":{\"height\":281,\"width\":224,\"style\":\"float: right;\",\"alt\":\"image caption\",\"title\":\"Image name\",\"class\":\"media-element file-full\"}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.