using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+.*?)(?:\s+(-)\s+)(.*?\d+)";
string substitution = @"$1$2$3";
string input = @"12 - 23
12 - -23
-12 - 23
-12 - -23";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}