const regex = /(\d+.*?)(?:\s+(-)\s+)(.*?\d+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+.*?)(?:\\s+(-)\\s+)(.*?\\d+)', 'gmi')
const str = `12 - 23
12 - -23
-12 - 23
-12 - -23`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);