// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\d+.*?)(?:\s+(-)\s+)(.*?\d+)").unwrap();
let string = "12 - 23
12 - -23
-12 - 23
-12 - -23";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}