# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:^|\s)[a-z])(?!nd\b|r\b)/$1/g;t' <<< "alexis Sanchez
sanchez's or ball
sanchez and co"