use strict;
my $str = 'alexis Sanchez
sanchez\'s or ball
sanchez and co';
my $regex = qr/((?:^|\s)[a-z])(?!nd\b|r\b)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";