re = /^(?!^\[[\d\-]+\]$)\[[\w][\w\-]*[\w]+\]$/m
str = '[Primeiro-Exemplo]
[Segundo-Exemplo-Valido]
[3-Exemplo-Valido]
[-3-Exemplo-Valido]
[1-2-3]
[Evento-4]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end